Houston, We Have a Problem (and Dell Should Be Ashamed of Themselves)

reliability01 Fans of this blog — and by "fans," I mean my mom and about 10,000 spambots — might recall that I bought a Dell XPS 720 back at the end of October, 2007. It didn’t work, so Dell swapped it for a replacement, which I finally got in January, 2008, after enough frustration to run some sort of futuristic locomotive that is powered entirely by frustration.

Well, the replacement didn’t work, either. And while I haven’t been blogging about it, I’ve spent the last 2 months troubleshooting the problem, with occasional (and relatively indifferent) assistance from Dell.

First, a very short summary: The XPS 720 locked up frequently (and by that, I mean the mouse would freeze, all desktop activity would cease, and then, after about a minute of eerie quiet, the machine would bluescreen and then reboot).

This tended to happen a few times each day, and generally seemed tied to high hard drive utilization, such as when installing an app from DVD or trying to back up the hard drive. Not always, though. Occasionally, it would just lock up and bluescreen when the system seemed relatively idle.

That was how the first XPS 720 behaved. It had come with with Windows Vista Home Premium installed, but as soon as I got it out of the box, I immediately upgraded the machine to Windows Vista Ultimate. But as soon as I began installing apps from DVD, I noticed it locked up intermittently. I contacted Dell, who had me try some common troubleshooting, and though we didn’t find any specific problems, Dell decided to send me a new machine.

When the new machine eventually arrived, I decided to leave Home Premium in place in case the upgrade to Ultimate was somehow to blame. Again, I started installing apps and, pretty quickly, I noticed this new machine was locking up just like the first PC. It continued to lock up on a frequent basis, making it borderline unusable. Now bear in mind that I wasn’t installing buggy, insane stuff with names like CrazyPhishingSpooferPro — I was installing Office, Photoshop, and a handful of popular games, all ordinary stuff that ran just fine on my old Windows Vista computer. For backup, I use (and continue to highly recommend) Casper to clone my hard drive to a second internal drive. It was incapable of making it all the way through a backup; the machine would routinely lock up before the backup was complete, leaving me without a backup. Check out the Reliability Monitor snapshot above for a peek at how my machine handled itself through the month of January.

Each time it crashed, Windows Error Reporting would tell me:

image

So Windows was implying there was a problem somewhere in the storage subsystem. Maybe the hard drive itself, or the hard drive controller, or perhaps some filter driver or software interfering with the hard drive operation. That certainly seemed plausible, since the system most commonly hung when the hard drive was doing heavy duty.

So here are just some of the ways I tried troubleshooting:

  • Disabled most of the services that seemed suspect, including the Sidebar, TIVO Desktop, and Startup apps like iTunes and Photoshop gunk
  • Uninstalled anti-virus software
  • Uninstalled Capser even though Future Systems tech support assured me Casper was completely benign
  • Checked all the cable connections to make sure they were secure
  • Ran Dell’s diagnostics that tests memory, hardware, and the hard drive, including SMART tests
  • Underclocked the processor
  • Ran MEMTEST and swapped out the RAM for different memory
  • Swapped the hard drive, installed Windows from scratch

Since I had the exact same problem on two computers, logic dictated that it was a software glitch, not a hardware problem. But even that seemed increasingly unlikely as I winnowed down the possible causes. I was going out of my mind–I had seemed to rule out hardware problems like CPU, motherboard, memory, or hard drive, and I was running a machine that had little more than a handful of extremely common applications on it. And trust me, I was pretty exhaustive in my troubleshooting efforts.

Which is more than I can say for Dell, which exhibited only mild interest in assisting me. Each time I called tech support, they’d pretty much start over with doing asinine Tier 1 troublshooting tricks like deleting the files out of the Temp folder and disabling stuff in the Startup folder. More than once I had a tech delete the files from Temp and insist valiantly that the problem was completely solved, not unlike poor Lieutenant Gorman, who insisted "the area is secure, Ripley."

Once I had a tech tell me to run a suite of tests overnight. He said that if the tests didn’t complete in 6 hours, there was something radically wrong. I called back the next day to say the tests had been running for 12 hours and were only a tiny fraction complete. ‘Never mind,’ the new tech said, ‘that test doesn’t tell you anything, and it can run for days.’ His solution? Wipe the hard drive and start from scratch to see if the problem went away. I got that kind of conflicting support on a number of occasions.

When I asked to be upgraded to Level 2 support, I’d be promised call backs which never came. I took to emailing Dell’s Unresolved Customer Service Issues every single day, and sent them perhaps 15 requests for support. Dell’s web page promises a reply within 24 hours, but they never responded to me. Ever. Not even once. Ever Ever.

Finally, after 2 months of this, I called customer service and asked to return the system. That’s finally when something started happening; a tech support rep scheduled a house call to replace the motherboard, CPU, and memory. For a week after the motherboard transplant, I didn’t have any bluescreens. Which was a record for the XPS 720, which would bluescreen on average once every 36 hours, assuming I was not trying to install software or back up the hard drive (in which case it would bluescreen more or less on cue). But then the bluescreens came back with a vengence. I had 4 in one day, then one or two the next. And yesterday, the machine bluescreened so many times I lost count — more than 6 times. And that’s after disconnecting every external peripheral.

In inserted a fresh hanrd drive, popped in a Windows CD, and watched in amazement as the computer bluescreened during initial setup.

So what isthe problem? Beats me. I’m now trying to get in touch with customer service to negotiate a refund. While I won’t fault Dell for the actual hardware problem, they definitely deserve all the credit for the worst customer service experience in recorded history. Just some of their crimes:

  • Losing my order. Several times.
  • Taking weeks and weeks longer than promised to ship. Twice — both on the original order and the warranty replacement.
  • Lying to me about the order status on more than one occasion.
  • Promising to send, but then refusing to honor, a $200 gift card promotion because of a rule no ordinary customer should be expected to anticipate.
  • Repeatedly failing to contact me or follow up on tech support.
  • Failing to offer on-site support or hardware replacement until I asked for a refund.
  • Providing generally crappy tech support that was far, far inferior to what I was capable of doing on my own.

And just in case you’re curious, no, I’ve never gotten anything like an apology from Dell for this fiasco. The closest I’ve gotten to an apology, in fact, was when they took away the $200 gift card I was supposed to get with my order. Could have been worse, I suppose — they could have kicked a puppy in my name.

3 Responses to “Houston, We Have a Problem (and Dell Should Be Ashamed of Themselves)”

  1. Tammy Says:

    Hi,

    I, too, am experiencing customer support issues with Dell. I have the XPS 720 and it’s less than 7 months old. I got the blue screen of death out of nowhere. As I am writing this, I am running the Dell diagnostic test (that you talked about) that the tech just told me would take 2 hours. I need to get my data off of the crashed drive but Dell tells me that even though it is still under warranty, they can’t assist me with data recovery.

    I have an emachine that still runs (slowly, but still runs) after 10 years. I wanted to hook up the XPS as a slave to the emachine but can’t because the emachine uses different cables and is “too old”. I told him that the emachine has far outlasted the XPS system. He seemed offended. So, I plan to take it somewhere and have them retrieve my data and do a clean install. Hopefully, this works.

    Also, I had spoken to a tech on Tuesday that was suppose to call me back on Friday but I’m still waiting on that phone call (it’s now Sunday evening). The extension that he gave me is wrong and nobody will transfer me to his voice mail.

    I’m to the point where I want to get a refund and buy anything BUT a Dell. Did you ever get a refund? Or get anything at all done since this post?

    Thanks,
    Tammy

  2. Dave Says:

    Hi Tammy,

    Sorry to hear about your troubles. Alas, I am ashamed to say that I simply got bored of constantly following up with Dell and pushing, pushing, pushing for a solution. They were very good and making it hard to get satisfaction, and eventually, they won. I gave up–I ran out of energy to call them daily and constantly try to follow up to get level 2 or level 3 tech support that simply never came.

    So these days, I continue to get several lockups/bluescreens each week, and my machine frequently fails when I need it to behave reliably the most, such as when it’s backing up. I secretly hope that when I can install Windows 7, that might fix the problem. Sigh. :-)

    Good luck with your troubles, though!

  3. advancedcardiodr Says:

    Thank you for sharing your valuable information.this information very useful for online learners

    diagnostic tests in houston

Leave a Reply